收藏本页 | 设为主页 | RSS
LOGO

我就上乐乐吧

LAMPP在64bitCentOs上运行LAMPP,会得到英文提醒:

您当前的位置:首页 » 技术杂萃
全站公告
重要提示!

本站收集各类美图,以无LOGO原汁原味图为主!欢迎大家交流。
怕失联,请认准如下地址:
微博:传送门
土豆:传送门
电报:传送门
微信:superimagelove
花瓣:传送门
Q群1:231151757
Q群2:583138281
文件解压密码:593668.com
热心赞助

站内搜索
 
相关文章
热门文章
热搜词组
文章归档
友情链接
解决LAMPP在64位CentOS上运行的问题

发布日期:2013-01-14  关键词: Linux Apache MySQL php CentOS

LAMPP在64bit CentOs上运行LAMPP,会得到英文提醒:
”XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility liBrary for your system”
这时可以采用如下办法解决:

1)安装32bit库
sudo yum -y install glibc.i686 libgcc.i686 libstdc++.i686

2) 修改启动脚本

# XAMPP is currently 32 bit only
case `uname -m` in
*_64)
if /opt/lampp/bin/php -v > /dev/null 2>&1
then
:
else
$de && echo "XAMPP gibt es zur Zeit nur als 32-Bit Applikation. Bitte verwende eine 32-Bit Kompatibilitaetsbibliothek fuer Dein System."
$de || echo "XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system."
exit
fi
;;
esac
改为:
# XAMPP is currently 32 bit only
#case `uname -m` in
# *_64)
# if /opt/lampp/bin/php -v > /dev/null 2>&1
# then
# :
# else
# $de && echo "XAMPP gibt es zur Zeit nur als 32-Bit Applikation. Bitte verwende eine 32-Bit Kompatibilitaetsbibliothek fuer Dein System."
# $de || echo "XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system."
# exit
# fi
# ;;
#esac

猜您喜欢:
Q群: 231151757微信:superimagelove 官网:www.593668.com